Result: setup_deb_repo : Install needed packages
Field Value
changed
True
msg
All items completed
results
[
    {
        "ansible_loop_var": "item",
        "cache_update_time": 1559313931,
        "cache_updated": false,
        "changed": true,
        "diff": {},
        "failed": false,
        "invocation": {
            "module_args": {
                "allow_unauthenticated": false,
                "autoclean": false,
                "autoremove": false,
                "cache_valid_time": 0,
                "deb": null,
                "default_release": null,
                "dpkg_options": "force-confdef,force-confold",
                "force": false,
                "force_apt_get": false,
                "install_recommends": null,
                "name": [
                    "dpkg-dev",
                    "equivs",
                    "libfile-fcntllock-perl"
                ],
                "only_upgrade": false,
                "package": [
                    "dpkg-dev",
                    "equivs",
                    "libfile-fcntllock-perl"
                ],
                "policy_rc_d": null,
                "purge": false,
                "state": "present",
                "update_cache": null,
                "upgrade": null
            }
        },
        "item": [
            "dpkg-dev",
            "equivs",
            "libfile-fcntllock-perl"
        ],
        "stderr": "debconf: delaying package configuration, since apt-utils is not installed\n",
        "stderr_lines": [
            "debconf: delaying package configuration, since apt-utils is not installed"
        ],
        "stdout": "Reading package lists...\nBuilding dependency tree...\nReading state information...\nThe following NEW packages will be installed:\n  equivs libfile-fcntllock-perl\n0 upgraded, 2 newly installed, 0 to remove and 86 not upgraded.\nNeed to get 52.5 kB of archives.\nAfter this operation, 184 kB of additional disk space will be used.\nGet:1 http://archive.ubuntu.com/ubuntu bionic/main amd64 libfile-fcntllock-perl amd64 0.22-3build2 [33.2 kB]\nGet:2 http://archive.ubuntu.com/ubuntu bionic/universe amd64 equivs all 2.1.0 [19.4 kB]\nFetched 52.5 kB in 0s (141 kB/s)\nSelecting previously unselected package libfile-fcntllock-perl.\r\n(Reading database ... \r(Reading database ... 5%\r(Reading database ... 10%\r(Reading database ... 15%\r(Reading database ... 20%\r(Reading database ... 25%\r(Reading database ... 30%\r(Reading database ... 35%\r(Reading database ... 40%\r(Reading database ... 45%\r(Reading database ... 50%\r(Reading database ... 55%\r(Reading database ... 60%\r(Reading database ... 65%\r(Reading database ... 70%\r(Reading database ... 75%\r(Reading database ... 80%\r(Reading database ... 85%\r(Reading database ... 90%\r(Reading database ... 95%\r(Reading database ... 100%\r(Reading database ... 21458 files and directories currently installed.)\r\nPreparing to unpack .../libfile-fcntllock-perl_0.22-3build2_amd64.deb ...\r\nUnpacking libfile-fcntllock-perl (0.22-3build2) ...\r\nSelecting previously unselected package equivs.\r\nPreparing to unpack .../archives/equivs_2.1.0_all.deb ...\r\nUnpacking equivs (2.1.0) ...\r\nSetting up equivs (2.1.0) ...\r\nSetting up libfile-fcntllock-perl (0.22-3build2) ...\r\nProcessing triggers for man-db (2.8.3-2ubuntu0.1) ...\r\n",
        "stdout_lines": [
            "Reading package lists...",
            "Building dependency tree...",
            "Reading state information...",
            "The following NEW packages will be installed:",
            "  equivs libfile-fcntllock-perl",
            "0 upgraded, 2 newly installed, 0 to remove and 86 not upgraded.",
            "Need to get 52.5 kB of archives.",
            "After this operation, 184 kB of additional disk space will be used.",
            "Get:1 http://archive.ubuntu.com/ubuntu bionic/main amd64 libfile-fcntllock-perl amd64 0.22-3build2 [33.2 kB]",
            "Get:2 http://archive.ubuntu.com/ubuntu bionic/universe amd64 equivs all 2.1.0 [19.4 kB]",
            "Fetched 52.5 kB in 0s (141 kB/s)",
            "Selecting previously unselected package libfile-fcntllock-perl.",
            "(Reading database ... ",
            "(Reading database ... 5%",
            "(Reading database ... 10%",
            "(Reading database ... 15%",
            "(Reading database ... 20%",
            "(Reading database ... 25%",
            "(Reading database ... 30%",
            "(Reading database ... 35%",
            "(Reading database ... 40%",
            "(Reading database ... 45%",
            "(Reading database ... 50%",
            "(Reading database ... 55%",
            "(Reading database ... 60%",
            "(Reading database ... 65%",
            "(Reading database ... 70%",
            "(Reading database ... 75%",
            "(Reading database ... 80%",
            "(Reading database ... 85%",
            "(Reading database ... 90%",
            "(Reading database ... 95%",
            "(Reading database ... 100%",
            "(Reading database ... 21458 files and directories currently installed.)",
            "Preparing to unpack .../libfile-fcntllock-perl_0.22-3build2_amd64.deb ...",
            "Unpacking libfile-fcntllock-perl (0.22-3build2) ...",
            "Selecting previously unselected package equivs.",
            "Preparing to unpack .../archives/equivs_2.1.0_all.deb ...",
            "Unpacking equivs (2.1.0) ...",
            "Setting up equivs (2.1.0) ...",
            "Setting up libfile-fcntllock-perl (0.22-3build2) ...",
            "Processing triggers for man-db (2.8.3-2ubuntu0.1) ..."
        ]
    }
]
warnings
[
    "Updating cache and auto-installing missing dependency: python3-apt",
    "Could not find aptitude. Using apt-get instead"
]